manage website down
Incident Report for NTP Pool
Resolved
This incident has been resolved.
Posted Jan 02, 2024 - 08:06 UTC
Monitoring
It's been resolved!

A change to prepare some other improvements wasn't sufficiently tested and made the system error out when logging in some users.
Posted Jan 02, 2024 - 08:06 UTC
Investigating
The management website is down for many users since January 1st around 10 in the morning UTC.
Posted Jan 01, 2024 - 09:58 UTC
This incident affected: Management Portal.